
APPLICATION DEVELOPMENT
LECTURE 6: INHERITANCE, USERINTERFACES

Part of SmartProducts

class AppDev {

}



▪ Inheritance

▪ (Prototyping) Userinterfaces

▪ Assignment

APPLICATION DEVELOPMENT

INTRODUCTION
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slides @ vanslooten.com/appdev

No lecture next week,

next lecture Tuesday June 4th

Fjodor van Slooten

W241 (Horst-wing West)

f.vanslooten@utwente.nl

https://home.ctw.utwente.nl/slootenvanf/appdev/


▪ Adding methods

▪ 5a: determine value of money from cents to euro’s €XX.XX

▪ 5b: determine return coins

▪ Modulo operator %: remainder* of division

5/24/2019AppDev 3

ASSIGNMENT 5

void Userinterface::printBalance() {
...
lcd->print(euros); lcd->print("."); lcd->print(cents);

}

int balance = 130; // 130 cents
int euros = balance / 100;
int cents = balance % 100;1

30

euros=

cents=

1.30
prints:

balance = balance - p.getPrice();
int coin50 = balance / 50;
balance = balance % 50;
int coin20 = ...

Assignment 5b
* The % operator returns the remainder of two numbers. For instance 

10 % 3 is 1 because 10 divided by 3 leaves a remainder of 1.



1. Scroll up in Console

2. Click on error (in own code) to go there
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CRASH…? APPLICATION NOT WORKING?

Error at line 250 

Finding a problem: debug or use System.out.println()

Print values of 

variables!

http://www.vogella.com/tutorials/EclipseDebugging/article.html
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PROTOTYPING USERINTERFACES
FROM DESIGN TO PROTOTYPE

With Axure, you can 

publish a prototype online:Software tools to make interactive demos & 

interfaces:

▪ Java

▪ Axure

▪ …



▪ Flexible, prototype 

apps, websites

▪ Create complex 

interactions

▪ Can be used for low-

& high fidelity 

prototypes

▪ License available on 

Canvas:

Application 

Development > Axure 

license

6

AXURE

axure.com

http://www.axure.com/


▪ Tutorials on 
axure.com/support

▪ Practice tutorial:
Build a prototype of 

interface for ATM:

7

LEARN

vanslooten.com/appdev >

Additional Online Materials,

UI Prototyping:

axure.com/support

https://home.et.utwente.nl/slootenvanf/appdev/?dir=appdev-addons/UI%20Prototyping
https://home.et.utwente.nl/slootenvanf/appdev/?dir=appdev-addons/UI%20Prototyping
https://home.et.utwente.nl/slootenvanf/appdev/?dir=appdev-addons/UI%20Prototyping
http://www.axure.com/support
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APP PROTOTYPING: APP INVENTOR
BUILD MOBILE APPS

ai2.appinventor.mit.edu

Learn: App Inventor tutorial,

App Inventor: Create your own Android Apps

Program

http://ai2.appinventor.mit.edu/
http://appinventor.mit.edu/explore/ai2/tutorials
http://www.appinventor.org/book2
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APP PROTOTYPING: APP INVENTOR
BUILD MOBILE APPS

ai2.appinventor.mit.edu

Learn: App Inventor tutorial,

App Inventor: Create your own Android Apps

Design

http://ai2.appinventor.mit.edu/
http://appinventor.mit.edu/explore/ai2/tutorials
http://www.appinventor.org/book2
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APP INVENTOR TUTORIAL
BUILD AN APP FOR A CONNECTED WEATHER STATION

Tutorial: Build an App with App Inventor which 

can display values of a connected sensor

More: Control an RGB LED from an Android 

App via Bluetooth

vanslooten.com/appdev >

Additional Online Materials,

UI Prototyping

https://home.et.utwente.nl/slootenvanf/2018/11/22/build-app-inventor-display-connected-sensor/
https://home.et.utwente.nl/slootenvanf/2019/02/28/control-rgb-led-bluetooth/
https://home.et.utwente.nl/slootenvanf/appdev/?dir=appdev-addons/UI%20Prototyping


▪ Small steps, iterate (while designing, already perform small tests)

▪ Test sensors, build small parts, write small test programs 

using examples

▪ Later on: put smaller parts together

▪ Don't try to design everything up front

▪ Just start (its better to start with sloppy code full of mistakes, than to 

postpone and wait for a better design)

▪ Never write more than 10 lines of code without testing
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FROM DESIGN TO  CODE

Rules of thumb: 

Making mistakes is 

the best way to learn



▪ Call a method, see result…

▪ Print statements!
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FROM DESIGN TO  CODE: HOW TO TEST?

void setup() {
// test methodX:
object.methodX(); // what happens?
Serial.println("MethodX just finished");
// Check output of print-statements in Serial Monitor

}

void loop() {
// get the reading(s) from sensor
light = lightSensor.readRaw();
Serial.print("light="); Serial.println(light);

}

Arduino/C++:

public MachineUI() { // constructor
// test methodX:
object.methodX(); // what happens?
System.out.println("MethodX just finished");
// Check output of print-statements in Console

}

void read() {
// get the reading(s) from sensor
light = lightSensor.readRaw();
System.out.println("light="+light);

}

Java:
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INHERITANCE

▪ New class inherits from existing

▪ Existing: superclass

▪ New: sub/derived class

▪ Sub is often extension (with new/other 

methods/properties)

public class Dog extends Animal {
}

Head First: p59-69, 134-137 Aan de slag met: 8.1-8.4



▪ ArrayList 'accepts' family members

▪ Who is who? instanceof
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INHERITANCE

ArrayList<DrawingObject> list;

list = new ArrayList<DrawingObject>();

Image i = new Image();
Ball b = new Ball();
list.add(i);
list.add(b);

// what is item x in the list?
if ( list.get(x) instanceof Ball )

System.out.println("It is a Ball!");

DrawingObject

Image Ball

DrawingObject is 

superclass

of Image and Ball

Is the element in 

the list of the type 

Ball? Or short: is 

this a Ball?
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INHERITANCE: CLASS DIAGRAM

▪ Choose Help > Install New Software from menu

▪ Enter update site: http://www.objectaid.com/update/current/

(press Enter)

▪ Select "ObjectAid UML Explorer“

▪ Press Next (2x)

▪ Accept license, Finish

Use:

File > New > Other, choose Object Aid UML Diagram > Class Diagram

http://www.objectaid.com/update/current/
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INHERITANCE: CLASS DIAGRAM

drag

drag

▪ Use: File > New > Other, choose Object Aid UML Diagram > Class Diagram

▪ Drag classes from package explorer into diagram



▪ Add images to style UI elements

▪ Layout, layers

▪ Borders, icons

▪ Advanced UI elements

▪ Create your own UI elements
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USER INTERFACES

Example: RoundPlayPauseButton

JKnob.java

https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/RoundPlayPauseButton.zip
https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/JKnob.java


▪ Once: Window > Preferences, 

WindowBuilder > Swing > LookAndFeel

▪ Per application: Top of WindowBuilder
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LOOK & FEEL

JButton button = new JButton("Update");
button.setUI((ButtonUI) BasicButtonUI.createUI(button));
button.setBackground(new Color(50, 205, 50));
button.setBorder(null);

Flat-design button?:



▪ Is container

▪ Separate parts of UI

▪ Each own layout

▪ Turn on/off: setVisible()
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PANEL

Example: Tea Maker

Panel with 12

buttons in Grid Layout

jPanelMain: main program

jPanelProgress: semi transparent progress bar

https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/Tea_maker.zip
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RADIO BUTTONS

▪ Select one from set of buttons

▪ Add buttons

▪ Group them: by adding them to a 

ButtonGroup

Part of today’s 

assignment



▪ Assignment 6b: highlighted border

▪ Via advanced properties
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BORDERS
CAN BE SET ON (ALMOST) ALL UI COMPONENTS



▪ Separators

▪ Tabs (Tabbed Pane)

▪ Split Pane

▪ Scroll Pane

▪ Layered Pane
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DIVIDE/ORGANISE PARTS OF UI



1. Place Tabbed Pane

2. Drag a Panel onto it (becomes 1st tab) (create user interface in that panel)

3. Add more tabs:

▪ Place new Panel next to tab

▪ If green plus-sign appears, release
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TABS
TABBED PANE

Tab 1

Tab 2
Tab 3

Read & demo: How to Use 

Tabbed Panes

http://docs.oracle.com/javase/tutorial/uiswing/components/tabbedpane.html
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SCROLL & SPLIT PANE

Read & demo: How to Use Split Panes, Scroll Panes

http://docs.oracle.com/javase/tutorial/uiswing/components/splitpane.html
http://docs.oracle.com/javase/tutorial/uiswing/components/scrollpane.html


▪ Build user interface in layers

▪ It is possible to turn layers on and off

setVisible()

▪ Layers can be transparent and overlap

setOpaque()
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LAYERED PANE

Example & demo: Assignment 5b 

& How to Use Layered Panes

Background of a label is transparent by 

default. If you want to assign a background 

color, make it opaque first: 
label.setOpaque(true)

Top layer

Bottom layer

https://docs.oracle.com/javase/tutorial/uiswing/components/layeredpane.html
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EVENTS: LISTEN TO KEYSTROKES
KEYS PRESSED ON KEYBOARD

GameGUI extends JFrame implements KeyListener {

@Override
public void keyPressed(KeyEvent e) {

System.out.println("key=" + e.getKeyCode() );
}

▪ Double-click element: 

propertyChange

▪ Change tab: stateChanged

Show Events

Example: catch-the-ball game

https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/Catch-the-ball.zip


▪ Images
▪ Use as icon*

▪ Or draw in a panel**

▪ Sound
▪ Use class PlayClip, part 

of example
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MEDIA: IMAGES AND SOUNDS

PlayClip sound = new PlayClip();

// check if basket catched something:
if (checkCatched(basket.getX(), basket.getY()))

sound.play("sound/Ding.wav");

// read image from file:
File file = new File("images/"+filename);
try {

image = ImageIO.read(file);
} catch (Exception e) {

System.err.println("Unable to read "+filename);
return;

}
// draw image:
if (image!=null)

g.drawImage(image, x, y, panel);

Example: catch-the-ball game,

* atm-tutorial,

** appendix assignment 2

https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/Catch-the-ball.zip
https://home.et.utwente.nl/slootenvanf/uidessim/java/


▪ Start with EVSHield-example 

nxt_light_reflected to measure light values

▪ Add to setup():

▪ Add to loop():
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ARDUINO: LINE FOLLOWER
USING ONE DOWN-FACING NXT LIGHT SENSOR

// start driving
evshield.bank_a.motorRunUnlimited(SH_Motor_Both, SH_Direction_Reverse, 15);

if (light<600) { // off track
evshield.bank_a.motorStop(SH_Motor_1, SH_Next_Action_Float );

}
else { // on track

evshield.bank_a.motorRunUnlimited(SH_Motor_Both, SH_Direction_Reverse, 15);
}
delay(50);

For higher precision, 

use 2 sensors, each 

next to the line

Linefollower.ino

https://home.et.utwente.nl/slootenvanf/div/arduino/Linefollower.ino


▪ Declare path as a class-variable

▪ Initialize it in a method

▪ How?
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DECLARATION AND INITIALIZATION

// find path from 0,0 to 40,40
List<ExampleNode> path = myMap.findPath(0, 0, 40, 40);

public class MyClass {
List<ExampleNode> path;

public void someMethod {
path = myMap.findPath(0, 0, 40, 40);

}

Need in assignment
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PATHFINDING… CLEAR THE PATH

if (path != null) { // remove previous path
for (int i = 0; i < path.size()-1; i++) {

PixelPanel p = pixelPanels[path.get(i).getxPosition()][path.get(i).getyPosition()];
if (p.getBackgroundColor()==Color.yellow) { // if shown as path

p.setBackgroundColor(Color.white);
}

}
}

Is there 

a path?

Need in assignment

size()-1: Loop over all tiles in the path, except 

the last (to prevent clearing the destination tile)

Re-color only tiles 

which are yellow



▪ Create an interactive map editor with path-finding 

capabilities

▪ Java assignment

▪ Next assignment will further extend this, so to do 

assignment 7, you need 6
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ASSIGNMENT #6

Slides, assignments etc @ vanslooten.com/appdev

Checkpoint

Check assignments results:

No lecture next week,

next lecture Tuesday June 4th

https://home.ctw.utwente.nl/slootenvanf/appdev/

