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» Doing assignments & project progress
= Game techniques & motion sensing

» Class: inheritance

» Userinterfaces

= Assignment
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INSERTING CODE... AT RIGHT SPOT

To get the charachter, we need to read it from the BLE connection. [ s KT TR 7o Lo Vel o T=Talal v Ao e (Fe i [0 =1y (o Ko 1 =
loop() method to realize this:

if(bleserial.available()){
charl = bleserial.read(); // read first character of string received via ELE

S/ Get humidity event and print its wvalue.

dht.humidity () .getEvent (sevent) ;

if (isnan(event.relative humidity)) [ 1
Serial.println{F("Errcr reading humidity!™)):

} . . o)
e1se | void setup() { How to avoid this”
if { charl == 'h' } | Use Auto format to
f/ first character received was a "h' |
Serial.print (F("Humidity: "}): } // end of setup structurg your code!
Serial.print{event.relative humidity): > next Sllde
Serial.println{F{"%")): VOid lOOp() {
}

S/ display humidity on display:
dtostrf (event.relative humidity, 3, 1, buf); // princ £l } // end of 100p
display.drawString {10, 7, buf):

fread charactar from the BLE connecticn
if {bleserial.availakle()) |
charl = bleserial.r=ad(); // read first character of string received via BLE

AppDev 5/14/2020 3
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CLASS DESIGN: PRODUCT CLASS

ASSIGNMENT 4, STEP 2

» Complains that example in lecture was Arduino code...

» Other examples on class design in previous lectures

Arduino (.h file):

class Product {
private:
String name;
int price; // in cents
public:
// constructor (fills in name and price)
Product(String n, int p);
// methods (getters)
String getName();
int getPrice();

UNIVERSITY OF TWENTE.

The constructor and getters can be
automatically added via the Source

Java: menu (Source > Generate ...)

public class Product {

private String name;
private int price; // in cents

// constructor (fills in name and price)
public Product(String n, int p);

// methods (getters)

public String getName() {

}

public int getPrice() {

}

}

AppDev 5/14/2020



ASSIGNMENT 4A
STEP 5

= |t will become difficult doing an assignment without really
understanding the code...

» For instance, you cannot do step 5 (of the Arduino variant) if you
do not understand how reading button values and analog values
works

= |f you do not understand the code in the given example sketch,
step 5 will be very hard to solve!!

UNIVERSITY OF TWENTE. AppDev  5/14/2020


https://www.arduino.cc/reference/en/language/functions/digital-io/digitalread/
https://www.arduino.cc/reference/en/language/functions/analog-io/analogread/
https://home.et.utwente.nl/slootenvanf/div/arduino/multi_button_check_analog_input_oled_display.ino

ASSIGNMENT 4B
STEP 5

= |t will become difficult doing an assignment without really
understanding code...

= Example... if you read this:

«++ setButtonLabel{int ..., String ...)

This method must set the text of the Button with the given button number (first parameter of type int) using the given
text (second parameter type String). The first parameter of € method is, therefore, the button number, the second the
text for the button. The integer can have a valu ween 0 and 5 (for a maximum of 5 buttons).

public void setButtonLabel(int button, String text) {

} public void setButtonLabel(int b, String t) {
} public void setButtonLabel(int number, String message) {
} public void setButtonLabel(int buttonNumber, String textButton) {
ljpdl\/ } public void setButtonLabel(int kingArthur, String herMajestyTheQueen) { 5/14/2020

}



ASSIGNMENT 4B
STEP 5

= |t will become difficult doing an assignment without really
understanding code...

= Example... if you read this:

» setButtonOutofstock(int ...)
Communicate that the relevant product has run out (with given button number) by Esuilgf=R{yEeeln gzl [ =4 o1V 1es ] R (o)

disabled.” The button will be grey and can no longer be clicked. You can use the setEnabled{) method of the Buttons for
his: call it with setEnabled(false)

public void setButtonOutOfStock(int button) {
if (button==0) btnl.setEnabled(false);
else ... // if button is 1, 2, 3, ...

UNIVERSITY OF TWENTE. AppDev  5/14/2020 7



AUTO FORMAT

Undo

Cut

= Arduino: Right-click > Auto Format or via
menu: Tools > Auto Format i

Delete

= Eclipse: Right-click > Source > Format or Select Al

-

=
5 o~

8 * Moving ball class.

g Fold

- .

@ * Parts of trajectory calculation thanky . } m

1 http://courses.c .wx'ashingtcn.Edu_.’ccu'Mlaiz_.’metnu—.ez_ L Qul;gle]a Or a Auto Format

2

3 Fiedor van 3leeten L o T g Comment/Uncomment | _ . "

5 #/ Toggle Comment Ctrl+7 v Increase Indent

6 public class Ball extends DrawingObject { Unda Ctrl+ 7 Remove Block Comment CtrI+Sh\.ﬂ+\ Decrease Indent
public static final double GRAVITY = -9.81; Revert File Enaun ETu T e it Copy for Forum

0 double velocity = 785 // 50-60 gen: 70 Save Ctrl+S Correct Indentation C.trl+l Copy as HTML

: Eiiﬁ:bi:EZngEl;;Si // 88-5@ gem: 65 Open Declaration B3 Format Ctrl+Shift+F : : =

3 int step = @; ’ Open Type Hierarchy F4 Soraten Format the Selected Text

4 ) . Open Call Hierarchy Ctrl+Alt+H Add Import Ctrl+Shift+M

5 double angleRadians, v¥Y, vX, totalTime, dT;

6 Show in Breadcrumb Alt+5hift+B Organize Imports Ctrl+Shift+ 0

7 Quick Qutline Ctrl+0 Sort Members...

82 public Ball (int w, int h) { . )

g super(w, h); Quick Type Hierarchy Ctrl+T Clean Up...

@ Random r = new Random(); i

1 0s iy ’ Override/Implement Methods...

2 color = new Color(r.nextInt(256), r.nextInt(256), r.ne Show In Alt+Shift+W > Generate Getters and Sefters...

3 idth = 15;

i \}:zight _ 1;} Cut Ctrl+X Generate Delegate Methods...

5 Copy Ctrl+C Generate hashCode() and equals(...

: ; - g’ Y = Copy Qualified Name Generate toString (...

7 =8; /

8 [ Paste Ctrl+V Generate Constructor using Fields...

9 // Randomize velocity & angle:

@ velocity = 78 + (18-r.nextInt(28)); Quick Fix Ctrl+1 =5 AppDeV 5/14/2020

- a.ngle =65 + (157r‘next1t|t(39)); Source Alt+Shift+5 > Externalize Strings...

2 //System.out.p (

S b L L WL L WL WL W R R R R R R RN R Db

Refactor Alt+Shifte Ty |



PROTOTYPE FOR PROJECT
HOW DO YOU DO?

= Now we enter second half of project

» Usually, developing software (coding + testing) takes 55%
of time (design + requirements = 40%)

= So to have enough time left, you should now start
developing prototype

B requirements

Estimation of time needed for p

UN'VERS'TY OF TWE NTE in development of a prototype



DISCUSS DESIGN WITH TUTOR?
PROJECT PROGRESS

AppDev Lecture 5 Quiz
= See questions in quiz with this lecture!

€ You require 0% to pass this quiz.

. - = Discuss outcome of quiz questions in your
1. Regarding REQUIREMENTS specification we are 1
The questions in this quiz are about your progress for the project. Give your personal opinion (you da group & With tutor

not have to check with your project team members). Use what you learn to discuss this in the group!
If you do not participate in the project, you may ignore this quiz!

Almost ready

Busy, unknown how much time this will take
Just started
Done

2. Regarding DESIGN (for prototype) we are 1

Just started
Busy, unknown how much time this will take
Almost ready

Done

3. Regarding CODING (for prototype) we are 1

{coding = programming)

. . AppD 5/14/2020 10
Take this quiz now PpoeY

Busy, unknown how much time this will take



https://home.et.utwente.nl/slootenvanf/quiz/appdev-lecture-5/
https://home.et.utwente.nl/slootenvanf/quiz/appdev-lecture-5/

GAME TECHNIQUES & MOTION SENSING

= Combine:
= ArraylList to store game elements
= Timer to draw game elements frequently (e.g. each 20ms)

~ ® ® Nextlecture (Arduino):

f‘“ » Use accelerometer/gyro sensor to ‘sense’ movement,
13 use that to control the game

UNIVERSITY OF TWENTE. AppDev

5/14/2020

11



TIMER Used in today’s

assignment

Library: javax.swing.Timer

= Declare:
. : Animation: Use timer to draw
// declare timer, e.g. as class variable: . . . ]
Timer t; something while changing its
position

= |n constructor:

// initialize timer:
// clock ticks every 20ms; call repaint() at each clock tick:
t = new Timer(20, (e) -> repaint() );

t.start(); // start the timer

/ Method repaint() is called
every clock tick

AppDev 5/14/2020 12



TIMER

public class DrawingPanel extends JPanel {
private Timer t;

public DrawingPanel() {

// initialize timer:
// repaint all elements at each clock Ei:;;______——ff . N
[ t = new Timer(20, (e) -> repaint() ); Ca €pa t()

Timer r
Hime S.ta s t.start(); // start the timer method at every
\_

protected void paintComponent(Graphics g) {
for (DrawingObject o : gameElements) { // for each element...
o.paintComponent(g)
}
}

public void stop() {
timer.stop();

} \
[ Method to stop timer ]

}

AppDev 5/14/2020 13




ARRAYLIST (REVISITED)
STORE GAME ELEMENTS

Class variable;

// class variable which can hold a list of game elements:
ArrayList<DrawingObject> gameElements;

Constructor, initialize the list (make a new empty list):

// create the list of game elements (which are DrawingObjects):
gameElements = new ArrayList<DrawingObject>();

Add a Ball:

public void newBall() {
Ball b = new Ball(getWidth(), getHeight());
gameElements.add(b); // add Ball b to the list of game elements
}

UNIVERSITY OF TWENTE. AppDev  5/14/2020

14



DRAW ALL GAME ELEMENTS
WITH A FOR-LOOP

javatpoint.com/for-each-loop

= For-each loop, simple...
®.

A

for (DrawingObject e: gameElements) { // for-each game element

e.paintComponent(g); // draw the element
Balls drawn }

over
launcher... ®

= But what if we want to draw last elements first? (reverse order)

// for each element in list...
for (int i=gameElements.size()-1; i»=0; i--) { // order last > first
gameElements.get(i).paintComponent(g); // draw element i

Balls drawn }
behind
launcher... ©

UNIVERSITY OF TWENTE. AppDev  5/14/2020 15


https://www.javatpoint.com/for-each-loop

GAME: RANDOM THINGS HAPPEN...

= Launch new Balls unexpectedly...

private Random r;

r = new Random();

if (r.nextInt(20) == 1) {
newBall();

}

]'.|| I” Score: T



public class

}

INHERITANCE

= New class inherits from existing

= EXisting: superclass Can write

= New: sub/derived class %

= Sub is often extension (with new/other 3%; z‘

methods/properties) / :

B Is yellow Is white
£ New Java Class Dog Sheep

Java Class
1y This package name is discouraged. By convention, package nz

Dog extends Animal { with a lowercase letter Canrun

Source folder: |Te5t.f5rc Can run (faSter)
Package: |An|ma\5 |

[JEnclosing typ
MNam Dog I ‘
Modifi ®) publ (O packag privat protected

odifiers: ic ] 3 ) _‘”"Ia £ AppDeV 5/14/2020 17
[Jabstract []final static
UNIVERSITY OF TWENTE. =




INHERITANCE

= ArrayList 'accepts' family members

= Who is who? instanceof

DrawingObject

Image

AN

Ball

UNIVERSITY OF TWENTE.

Is the element in

the list of the type

Ball? Or short: is
this a Ball?

DrawingObject is
superclass
of Image and Ball

v
ArrayList<DrawingObject> list;

list = new ArrayList<DrawingObject>();

Image i = new Image();
Ball b = new Ball();
list.add(i);
list.add(b);

// what is item x in the 1list?

if ( list.get(x) instanceof Ball )
System.out.println("It is a Ball!");

AppDev 5/14/2020 18



INHERITANCE: CLASS DIAGRAM

= Choose Help > Install New Software from menu

= Follow instructions as detailed here

Use:
File > New > Other, choose Object Aid UML Diagram > Class Diagram

& New UML Class Diagram

Create a new UML Class Diagram

Choose a folder and file name for the new UML class diagram.
can also change the display and reverse engineering options fi

Folder: | fAssignmentf

NameI | Class diagram|

[] Save Image with Diagram as | PNG

UNIVERSITY OF TWENTE.

T3, Class Diagram.ucls 53

<<lava Classs»
(2 Animal

Animals

& Animal)

=<lava Class=»

(®Dog

Animals

@ Dog()

/N

==]ava Class=>
(2 Sheep

Animals

& Sheep(}

2 Install

Available Software

Check the items that you wish to install.

Work with | http:/www.objectaid.com/update/current/

type filter text

Marne
10 ObjectAid UML Explorer

AppDev

5/14/2020
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https://www.objectaid.com/install-objectaid

INHERITANCE: CLASS DIAGRAM

v i Animals

[3] Animal.jav
[J] Dog.java

[J] Sheep.java
T2 Class Diagram.u

Class Diagram.ucls
g

Use: File > New > Other, choose Object Aid UML Diagram > Class Diagram
Drag classes from package explorer into diagram

drag

5

«<Java Class=»
(= Animal

Animals

& Animal()

<<lava Class=»

(®Dog

Animals

& Dog()

UNIVERSITY OF TWENTE.

A

==Java Class=>

(2 Sheep

Animals

& Sheep()

[% Package Explorer 52 =N

',é Agsignment3
B Assignmentdb
',7‘1 Assignment3b
v = Assignmentf
Eh JRE System Library [JavaSE-1.8]
v 4B s
v i pathfinding
rlj AbstractMode,java
[J] ExampleFactory.java
[J] ExampleNode.java
[J] ExampleUsage.java
7| Map.java
r_ﬁ' MNodeFactory.java
[3] package-info.java
=| LICENSE
w [ userinterface
[3] ColorListener.java
17| PixelPaneljava

v = H

drag

%2 *Class diagram.ucls 52

ignmentf,/C

ss dia

«=Java Class=>
(9 Userinterface

userinterface

«<Java Class=»
(3 ColorListener

userinterface

o contentPane: JPanel

of tilgType: ButtonGroup

4 width: int

& height: int

4 start: int

4 starty” int

4 destinationX: int

4 destination” int

& map: Map<ExampleNode>
4 path: List=ExampleNode=

17| Userinterface.j
T2 Class diagram.ucls
',5 Assignmentf_uitwerking
v ',é Assignment?
B\ JRE System Library [JavaSE-1.8]
B src
i# pathfinding

"

& main(String[])-void
OcLlserinterfﬁce(}

@ getTileType():String

@ setStart(PxelPanel):void

@ setDestination(PixelPanel):void

@ setWalkable(PixelPanel boolean ):void
@ calcPath():void

Oc ColorListener(PixelPanel,Userinterface)
@ mousePressed(MouseEvent):void

0.1
-panel b 0.1
=«lJava Claszs=>
(® PixelPanel
~pixel els userinterface

0.+ | % POEL_SZE int

@ row: int

@ column: int

o backgroundColor: Color

& PixelPanel(int,int)

@ getBackgroundColor():Color

@ setBackgroundColor(Color):void
< paintComponent(Graphics):void




CLASS DIAGRAM

==java Class>»
(& Gamell ==/ava Class>>

S Make class diagrams with Eclipse plugin.

& main(Stringl])-void o x:int

e o File > New > Other, ObjectAid Class Diagram

@ keyPressed{KeyEvent)-void
@ keyReleased(KeyEvent)vaid © dx:int

o oo e Open the class diagram (its in the Package Explorer)

< paneMidth: int
 panelHeight: int

Drag classes (.java files) from Package Explorer into

-panel 0.1 % height: int
<<lava Class>> & Draw ingObject(int inf) t h d H
(3 DrawingPanel chra-n-ingObject(im int.int,int) e Iag ral I I
view @ getWidth)-int
a t Timer @ setiidth{int)void

a r: Random - @ getDx()int 1
o score: int (SAmeERnEn® ) @ sex(ingvaia n Sta t e D u q = I n
________—————__"___0—*> ® getDy()int

& Draw ingPanel)
@ setDy(intyvaid

< paintCompanent(Graphics)-vaid

@ new Launcher(}-vaid @ getHsight()int =xJava Class>>
@ new Basket{)void _panel @ setheight(int)-void (©Ball
@ left:vaid 3 @ getGolor(}:Color model
@ right()vaid : @ setColor(Golor)-void %FGRAVITY: double
@ new Ball()-vaid @ getPanelWidth()-int 4 velocity. doutle
& captured(intint)-boglean <<lava Cass>> @ setPanelidthint)void 4 angle: double
&image @ getPanelHeight():int & steps: int
_ang\ o 0.1 model -] sELF\a?EIHelghI(\nL;.vaid o step: int
© image Bufferedimage @ getX()int 2 angleRadians: double
s<lava Class== & image(String Draw ingPaneLint int) ol etk youd 4 VY. double
©PlayClip @ get() Butferedimage © getY(yint 4 v doudle
view © set{Buffaredimags)void @ l=Eii (et o a totalTime: double
o playClip- String © paintCampanent(Graphics)-void @ visible()-boclean 2 dT: double
o cip: Cip (f‘paﬁmcomp.onem{Graphfcs) void T
&Py Clip(String) moveoid © paintComponent(Graphics)-vaid
B intSound(String):Ciip @ move()veid
@ play(String)-int _law 0.1 m position{doutle double double) double
@ play()int
0.1 <<Java Class»>
(3 ControlElement
model

o movel- boolean

AppDev 5/14/2020 21

& ControlBement(String Draw ingPaneLint inf)

& getiovel; bodean (click to open larger version)

@ setMovel(boolean)-void
@ move()vaid



https://home.et.utwente.nl/slootenvanf/div/appdev/classdiagram.png
https://www.objectaid.com/install-objectaid
https://home.et.utwente.nl/slootenvanf/div/appdev/classdiagram.png

USER INTERFACES

= Add images to style Ul elements
= Layout, layers

= Borders, icons

» Advanced Ul elements

= Create your own Ul elements

K -

Example: RoundPlayPauseButton @

i ——

JKnob.java UNIVERSITY OF TWENTE. AppDev 5/14/2020 22


https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/RoundPlayPauseButton.zip
https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/JKnob.java

LOOK & FEEL |

Mew I Hew

LookAndFeel
= Once: Window > Preferences, ] Apply choosen LookAndFeel in main(} method
WindowBuilder > Swing > LookAndFeel =~

= Per application: Top of WindowBuilder & <ytem> - | F =

Windows

Mol | 00|

v <system>

<undefined:=
Flat-design button?: el IRE , Metal
¢ Add more... Nimbus

CDE/Motif
JButton button = new JButton("Update"); Windows
button.setUI((ButtonUI) BasicButtonUI.createUI(button)); Windows Classic
button.setBackground(new Color(50, 205, 50));
button.setBorder(null);

AppDev 5/14/2020 23
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PANEL

|s container

Separate parts of Ul
Each own layout

Turn on/off: setVisible()

Panel with 12
buttons in Grid Layout

jPanelMain: main program
jPanelProgress: semi transparent progress bar

UNIVERSITY OF TWENTE.



https://home.et.utwente.nl/slootenvanf/wp-content/uploads/appdev-download/eclipse_projects/Tea_maker.zip

Choose Duke's Layer and Position

LAYERED PANE

Cyan (2) - Top Position in Layer

Move the Mouse to Move Duke

= Build user interface in layers Yellow (0)
» |tis possible to turn layers on and off
setVisible()

» |Layers can be transparent and overlap

v [] (javax.swing.JFrame) - "Soda machine"

v [ | contentPane setOpaque( )
v U7 layeredPane

v I”j";! ﬁ Y Top layer Background of a label is transparent by
1 display F default. If you want to assign a background w

&3 button10 - "10"
™

color, make it opaque first:
&3 button20 - "20"
Sk i label. setOpaque (true)

v || panelButtons
23 btn1 - "Cola €1.00"
23 btn2 - "Sprite €1.00"
3 btn3 - "Cassis €1.00" .
83 btnd - "Apple juice €0 Example & demo: Assignment 5b

£5 btn5 - "Spawater €08 Bottom layer |, & How to Use Layered Panes
43 background - ""



https://docs.oracle.com/javase/tutorial/uiswing/components/layeredpane.html

EVENTS: LISTEN TO KEYSTROKES
KEYS PRESSED ON KEYBOARD

= Double-click element: GameGUI extends JFrame@ Ke@

propertyChange
@Override
= Change tab: stateChanged public void keyPressed(KeyEvent e) {
System.out.println("key=" + e.getKeyCode() );
=l Properties = }

ancestor

= change
stateChanged

compeonent

Show Events

container
focus

hierarchy
hierarchyBounds  []
inputMethod [
key (1
Mmouse [
mouselMation [
maouseWheel [

[# propertyChange  [] ,ENTE
[+ vetoableChange  []




MEDIA: IMAGES AND SOUNDS

// read image from file:

|

|mageS File file = new File("images/"+filename);
= Use asicon* try {

image = ImageIO.read(file);

1 *%*
= Ordrawina panel } catch (Exception e) {
T Properties “©| ® Lol B System.err.println("Unable to read "+filename);
background | 240,240,240 | A return;
displayedMn... }
enabled [“]true .
font Tahoma 11 = // draw image:
foreground 0,00 if (image!=nu11)
—oepteal iGHIMI > g.drawImage(image, x, y, panel);
icon asspath: logo.png
text"ul ID Bank v
PlayClip sound = new PlayCli H
= Sound yClip yClip();
= Use class PlayClip, part // check if basket catched something:
of today’s assignment if (checkCatched(basket.getX(), basket.getY()))

= sound.play("sound/Ding.wav");

UNIVERSITY OF TWENTE. AppDev  5/14/2020 27



LAST YEAR: WHEELED VEHICLES & LEGO

» |nterested? Check out last years presentations
= Would like to use Lego for project?

. Ask Fjodor, one project group member can pickup Lego



https://home.et.utwente.nl/slootenvanf/2019/04/04/lego-rover-car/

ASSIGNMENT #5 This afteman: teacher

available for help with project

» Build Catch-the-ball game
. .

For this assignment, you will make a simple game in which balls are launched, which we then must catch.
The user of the game controls a basket in which the balls must be collected. The aim is to catch as many
balls as possible and earn points that way.

The basket is located at the bottom of the screen and can only moy, the left and right. The balls come
from a launcher which launches balls with random trajectories and ds.

4 il


https://home.ctw.utwente.nl/slootenvanf/appdev/

